Although the filer can have multiple network interfaces, it does not function as a router. The Data ONTAP software does not route packets between the interfaces of the filer on behalf of other network hosts; however, it can route its own packets.
To route Network File System (NFS) over User Datagram Protocol (UDP) and all TCP traffic, Data ONTAP uses a mechanism called fast path. For all other IP traffic Data ONTAP uses the information available in the kernel routing table. The kernel routing table is maintained by a daemon called routed.
Note
Data ONTAP always uses conventional IP routing table lookups for routing all traffic on a FORE/IP Asynchronous Transfer mode (ATM) interface.
Fast path is an alternate routing mechanism available in Data ONTAP. Instead of using the routing table of the filer to route, this mechanism uses the source Media Access Control (MAC) address of the incoming packet as the destination MAC address of the outgoing packet for NFS-over-UDP and TCP traffic transmitted from the filer. Using this mechanism provides the following advantages:
The load balancing is achieved by sending responses on the same interface of the filer as incoming requests.
The increase in filer performance is achieved by skipping routing table lookups.
Fast path is enabled automatically on the filer; however, you can disable it.
The NFS-over-UDP traffic uses fast path only when sending a reply to a request. The reply packet is sent out on the same interface that the request packet came in on. For example, a filer named toaster uses the toaster-e1 interface to send reply packets in response to NFS-over-UDP requests received on the toaster-e1 interface.
Because data is acknowledged as part of the TCP protocol, Data ONTAP can use fast path on every TCP packet transmitted except the very first SYN packet (if Data ONTAP initiates a connection). For fast path, the interface used to transmit a packet is the same interface the last packet was received on.
For TCP connections, Data ONTAP automatically turns off fast path if it detects that using fast path in a network setup is not optimal.
If fast path is enabled and the routed daemon on a filer stops working, you might notice that telnet sessions to a filer can still be established from a non-local subnet, even though you cannot ping the filer interfaces. This happens because the fast path mechanism skips routing table lookups. As a result, the routing table is not used to respond to any NFS-over-UDP or TCP connection requests. Therefore,Telnet requests (TCP) succeed, while ping requests (ICMP) fail.
If fast path is enabled on a filer in an asymmetric network, the destination MAC address of the response packet will be that of the router that forwarded the incoming packet. However, in asymmetric networks the router forwarding packets to the filer is not the one forwarding the packets that the filer sends back. Therefore, you might have to disable fast path.
To manage the routing table, Data ONTAP invokes the routed daemon at boot time. The routed implementation in Data ONTAP is similar to the conventional UNIX implementation. It supports RIPv1 (RFC 1058), RIPv2 (RFC 1723), and the ICMP Router Discovery Protocol (RFC 1256).
Generally, routed acts as a silent router and never broadcasts its routing table. However, you can set routed to generate RIP response messages that advertise a host route to the primary interface of the filer.
For more information about routed, see the na_routed(1) man page.
Data ONTAP uses the default route entry to route to destinations that it does not explicitly know about in its routing table. You can set the default route in Data ONTAP either during the initial setup or later by modifying the /etc/rc file.
If you are upgrading your filer to Data ONTAP 6.0 or later and currently use the /etc/dgateways file to set a default route, Network Appliance recommends that you use the /etc/rc file, router discovery, or RIP instead. The /etc/dgateways file was deprecated in Data ONTAP 6.0.
The following sample /etc/rc file shows the route add command used to add a default route.
hostname tpubs-f720
ifconfig e0 172.28.50.21 netmask 255.255.255.0 mediatype 100tx-fd
route add default 172.28.50.1 1
routed on
Copyright © 1994-2003, Network Appliance, Inc. All rights
reserved.
Part No. 210-00321
File: routing2.htm
Last updated: 01/20/03 14:16:49