Understanding traps in Data ONTAP
About traps
You set traps to inspect the value of MIB variables periodically. Whenever the value of a MIB variable meets the conditions you specify, a trap is sent to the network management stations on the traphost list. The traphost list specifies the network management stations that receive the trap information.
You can set traps on any numeric variable in the MIB. For example, you can set a trap to monitor the fans on a filer and have the SNMP application on your network management station show a flashing message on your console when a fan has ceased operation.
Traps are persistent. After you set a trap, it exists across reboots until you remove it or modify it.
Types of traps in Data ONTAP
There are two types of traps in Data ONTAP:
- Built-in--Built-in traps are predefined in Data ONTAP and are automatically sent to the network management stations on the traphost list if an event occurs. These traps are based on
- RFC 1213, such as coldStart, linkDown, linkUp, and authenticationFailure
- Specific traps defined in the Network Appliance custom MIB, such as diskFailedShutdown, cpuTooBusy, and volumeNearlyFull
- User-defined--User-defined traps exist only after they are defined by a series of snmp traps commands.
Where to get further information
See the following RFCs for more information:
- RFC 1157--Defines and describes SNMP.
- RFC 1213--Defines and describes the SNMP MIB-II specification.
- RFC 1155--Defines and describes the structure and identification of managmenent information for TCP/IP-based internets.
- RFC 1215--Defines the onvention for defining traps for use with SNMP.
- RFC 1212--Gives concise MIB definitions.
Copyright © 1994-2003, Network Appliance, Inc. All rights
reserved.
Part No. 210-00321
File: snmp5.htm
Last updated: 01/20/03 14:16:54