ManageONTAP™ SDK

          

 

ManageONTAP Interfaces and their Documentation


Versions

This table shows the different versions of ONTAP and the versions of the various interfaces that each supports. Clicking on a particular version number will take you to the documentation for that version of the interface.   The NDMP specs may be found at http://www.ndmp.org.   CIM specifications are available at www.dmtf.org and SMI-S specifications at www.snia.org for SNIA members.

 
ONTAP
Netapp
SNMP MIB
Other MIBs
NDMP
ONTAPI
Windows RPC
compatibility

CIM/SMI-S
(requires proxy)
6.0 1.2 RFC1213 3 n/a no docs  
6.1 1.5 RFC1213 3 n/a no docs  
6.2 1.9 RFC1213 4 n/a no docs  
6.3 1.11 RFC1213 4 1.0 no docs  
6.4 1.13 RFC1213 4 1.1 6.4  
6.4.1 1.13 RFC1213 4 1.2 6.4 1.0
6.5 1.15

RFC1213
iSCSI

RFC2452
RFC2454
RFC2465
RFC2466

4 1.3 6.4 1.0
7g 1.17 RFC1213
iSCSI

RFC2452
RFC2454
RFC2465
RFC2466
4 1.4 7g 1.0
7.1 1.19 RFC1213
iSCSI

RFC2452
RFC2454
RFC2465
RFC2466
4 1.5 7g 1.0
7.2 1.19 RFC1213
iSCSI

RFC2452
RFC2454
RFC2465
RFC2466
4 1.6 7g 1.0

* Fpolicy versions are informal indications only. Please see the fpolicy documentation in each version of the SDK for complete information.

Support


Developer feedback is very important to us. Please contact your Network Appliance representative or technical contact with suggestions and requirements, or write to sdk-feedback@netapp.com.