|
|
Data ONTAP® PowerShell Toolkit
|
Cmdlet: Set-NcLdapClientSchema
NAME
Set-NcLdapClientSchema
SYNOPSIS
Modify an existing Lightweight Directory Access Protocol (LDAP) schema confi
guration.
SYNTAX
Set-NcLdapClientSchema [-Name] <String> [-Comment <String>] [-PosixAccount <
String>] [-PosixGroup <String>] [-NisNetgroup <String>] [-Uid <String>] [-Ui
dNumber <String>] [-GidNumber <String>] [-GroupCn <String>] [-NetGroupCn <St
ring>] [-UserPassword <String>] [-Gecos <String>] [-HomeDirectory <String>]
[-LoginShell <String>] [-MemberUid <String>] [-MemberNisNetgroup <String>] [
-NisNetgroupTriple <String>] [-WindowsAccount <String>] [-VserverContext <St
ring>] [-Controller <NcController[]>] [<CommonParameters>]
DESCRIPTION
Modify an existing Lightweight Directory Access Protocol (LDAP) schema confi
guration. If the LDAP server that the storage system needs to query does not
support any of the default read-only schemas, Copy-NcLdapClientSchema can
be used to create a editable copy of an existing read-only schema.
The cmdlet works in the cluster context for Data ONTAP versions prior to 8.2
. In Data ONTAP 8.2 and later, the cmdlet works in the vserver context.
PARAMETERS
-Name <String>
A name for the schema.
Required? true
Position? 1
Default value
Accept pipeline input? true (ByPropertyName)
Accept wildcard characters? false
-Comment <String>
A comment that can be associated with the schema.
Required? false
Position? named
Default value
Accept pipeline input? true (ByPropertyName)
Accept wildcard characters? false
-PosixAccount <String>
Name that represents the RFC 2307 posixAccount object class.
Required? false
Position? named
Default value
Accept pipeline input? true (ByPropertyName)
Accept wildcard characters? false
-PosixGroup <String>
Name that represents the RFC 2307 posixGroup object class.
Required? false
Position? named
Default value
Accept pipeline input? true (ByPropertyName)
Accept wildcard characters? false
-NisNetgroup <String>
Name that represents the RFC 2307 nisNetgroup object class.
Required? false
Position? named
Default value
Accept pipeline input? true (ByPropertyName)
Accept wildcard characters? false
-Uid <String>
Name that represents the RFC 1274 userid attribute used by RFC 2307 as u
id.
Required? false
Position? named
Default value
Accept pipeline input? true (ByPropertyName)
Accept wildcard characters? false
-UidNumber <String>
Name that represents the RFC 2307 uidNumber attribute.
Required? false
Position? named
Default value
Accept pipeline input? true (ByPropertyName)
Accept wildcard characters? false
-GidNumber <String>
Name that represents the RFC 2307 gidNumber attribute.
Required? false
Position? named
Default value
Accept pipeline input? true (ByPropertyName)
Accept wildcard characters? false
-GroupCn <String>
Name that represents the RFC 2256 cn attribute used by RFC 2307 when wor
king with groups.
Required? false
Position? named
Default value
Accept pipeline input? true (ByPropertyName)
Accept wildcard characters? false
-NetGroupCn <String>
Name that represents the RFC 2256 cn attribute used by RFC 2307 when wor
king with netgroups.
Required? false
Position? named
Default value
Accept pipeline input? true (ByPropertyName)
Accept wildcard characters? false
-UserPassword <String>
Name that represents the RFC 2256 userPassword attribute used by RFC 230
7.
Required? false
Position? named
Default value
Accept pipeline input? true (ByPropertyName)
Accept wildcard characters? false
-Gecos <String>
Name that represents the RFC 2307 gecos attribute.
Required? false
Position? named
Default value
Accept pipeline input? true (ByPropertyName)
Accept wildcard characters? false
-HomeDirectory <String>
Name that represents the RFC 2307 homeDirectory attribute.
Required? false
Position? named
Default value
Accept pipeline input? true (ByPropertyName)
Accept wildcard characters? false
-LoginShell <String>
Name that represents the RFC 2307 loginShell attribute.
Required? false
Position? named
Default value
Accept pipeline input? true (ByPropertyName)
Accept wildcard characters? false
-MemberUid <String>
Name that represents the RFC 2307 memberUid attribute.
Required? false
Position? named
Default value
Accept pipeline input? true (ByPropertyName)
Accept wildcard characters? false
-MemberNisNetgroup <String>
Name that represents the RFC 2307 memberNisNetgroup attribute.
Required? false
Position? named
Default value
Accept pipeline input? true (ByPropertyName)
Accept wildcard characters? false
-NisNetgroupTriple <String>
Name that represents the RFC 2307 nisNetgroupTriple attribute.
Required? false
Position? named
Default value
Accept pipeline input? true (ByPropertyName)
Accept wildcard characters? false
-WindowsAccount <String>
Attribute name to be used to get the windows account information for a u
nix user account.
Required? false
Position? named
Default value
Accept pipeline input? true (ByPropertyName)
Accept wildcard characters? false
-VserverContext <String>
Vserver to which to direct this command. If the currently connected con
troller (as embodied by an NcController object) represents a cluster, th
ere are multiple means to address commands to one of its vservers. Eith
er set the Vserver field on the NcController object to direct all subseq
uent commands to that vserver, or supply the VserverContext parameter to
an individual cmdlet. Only cmdlets which may be invoked on vservers of
fer the VserverContext parameter.
Required? false
Position? named
Default value
Accept pipeline input? false
Accept wildcard characters? false
-Controller <NcController[]>
A clustered Data ONTAP controller to receive this cmdlet, as embodied by
an NcController object. This parameter is returned by the Connect-NcCo
ntroller cmdlet. If not specified, the value in the global variable Cur
rentNcController is used. In the latter case, if CurrentNcController co
ntains a collection of NcController objects, this cmdlet is invoked on e
ach controller in succession.
Required? false
Position? named
Default value
Accept pipeline input? true (ByValue, ByPropertyName)
Accept wildcard characters? false
<CommonParameters>
This cmdlet supports the common parameters: Verbose, Debug,
ErrorAction, ErrorVariable, WarningAction, WarningVariable,
OutBuffer and OutVariable. For more information, type,
"get-help about_commonparameters".
INPUTS
OUTPUTS
DataONTAP.C.Types.Ldap.LdapClientSchema
NOTES
Category: ldap
API: ldap-client-schema-modify
Family: cluster,vserver
-------------- Example 1 --------------
C:\PS>Set-NcLdapClientSchema AD-SFU-copy -Comment "This is a (read-write) co
py of AD-SFU."
Set the comment for the LDAP client schema AD-SFU-copy.
Schema : AD-SFU-copy
NcController : 192.168.182.144
CnGroupAttribute : cn
CnNetgroupAttribute : name
Comment : This is a (read-write) copy of AD-SFU.
GecosAttribute : name
GidNumberAttribute : gidNumber
HomeDirectoryAttribute : unixHomeDirectory
LoginShellAttribute : loginShell
MemberNisNetgroupAttribute : memberNisNetgroup
MemberUidAttribute : primaryGroupID
NisNetgroupObjectClass : nisNetgroup
NisNetgroupTripleAttribute : nisNetgroupTriple
PosixAccountObjectClass : User
PosixGroupObjectClass : Group
UidAttribute : uid
UidNumberAttribute : uidNumber
UserPasswordAttribute : unixUserPassword
WindowsAccountAttribute : windowsAccount
RELATED LINKS
Get-NcLdapClientSchema
Copy-NcLdapClientSchema
Remove-NcLdapClientSchema
| Copyright © 2013 NetApp. All rights reserved. Use is subject to license terms. |
|
Data ONTAP® PowerShell Toolkit
|